Interruption to Support Phone Line

Incident Report for Cync System

Resolved

This issue has been resolved.
Posted Jun 13, 2023 - 17:10 EDT

Investigating

Cync Support is currently experiencing an interruption to our phone service. We are working with our phone service provider to restore functionality as quickly as possible.
Posted Jun 13, 2023 - 15:18 EDT
This incident affected: Cync Customer Support (Phone Support).