We appreciate your patience. Our interruption in support services is now resolved.
Posted Mar 30, 2023 - 15:18 EDT
Identified
We are currently experiencing an interruption with our support phone line and live chat services. We are working to resolve this as quickly as possible, and appreciate your patience. Please check this page for further updates.
Posted Mar 30, 2023 - 13:47 EDT
This incident affected: Cync Customer Support (Phone Support, Live Chat, Email/Webform).